Building a core network with evpn-mpls

Hi,

I'm busy designing a EVPN-MPLS networking configuration using EVPN, MPLS, ECMP, OSPF, LDP and RSVP.

Below are some lab configs (working config).

show | no-more 
## Last changed: 2018-10-22 13:47:35 UTC
version 14.1R1.10;
system {
    host-name IX;
    root-authentication {
        encrypted-password "$1$iiqdh9ru$CBQygri2MkpfgtgdGo8GO1"; ## SECRET-DATA
    }
    login {
        user lab {
            uid 2000;
            class super-user;
            authentication {
                encrypted-password "$1$oW1NeMUu$N7IVMfy8GfJ02jzQzJ39h/"; ## SECRET-DATA
            }
        }
    }
    services {
        telnet {
            connection-limit 5;
        }
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    ge-0/0/0 {
        description "IX <> GS #1";
        mtu 2000;
        mac 50:01:00:01:00:02;
        unit 0 {
            family inet {
                address 10.0.0.1/30;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        description "IX <> GS #2";
        mtu 2000;
        mac 50:01:00:01:00:03;
        unit 0 {
            family inet {
                address 10.0.1.1/30;
            }
            family mpls;
        }
    }
    ge-0/0/2 {
        description "IX <> AM6 #1";
        mtu 2000;
        mac 50:01:00:01:00:04;
        unit 0 {
            family inet {
                address 10.0.0.5/30;
            }
            family mpls;
        }
    }
    ge-0/0/3 {
        description "IX <> AM6 #2";
        mtu 2000;
        mac 50:01:00:01:00:05;
        unit 0 {
            family inet {
                address 10.0.1.5/30;
            }
            family mpls;
        }
    }
    ge-0/0/4 {
        description "IX <> DC2 #1";
        mtu 2000;
        mac 50:01:00:01:00:06;
        unit 0 {
            family inet {
                address 10.0.0.9/30;
            }
            family mpls;
        }
    }
    ge-0/0/5 {
        description "IX <> DC2 #2";
        mtu 2000;
        mac 50:01:00:01:00:07;
        unit 0 {
            family inet {
                address 10.0.1.9/30;
            }
            family mpls;
        }
    }
    ge-0/0/9 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        mac 50:01:00:01:00:0b;
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    em0 {
        unit 0 {
            family inet {
                address 192.168.56.10/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.10.10.1/32;
            }
        }
    }
}
routing-options {
    router-id 10.10.10.1;
    autonomous-system 65000;
    forwarding-table {
        export lbp;
    }
}
protocols {
    rsvp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    mpls {
        no-cspf;
        label-switched-path IX-to-GS {
            to 10.10.10.2;
        }
        label-switched-path IX-to-DC2 {
            to 10.10.10.3;
        }
        label-switched-path IX-to-AM6 {
            to 10.10.10.4;
        }
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    bgp {
        group EVPN {
            type internal;
            local-address 10.10.10.1;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            multipath;
            neighbor 10.10.10.2;
            neighbor 10.10.10.3;
            neighbor 10.10.10.4;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ge-0/0/0.0;
            interface ge-0/0/1.0;
            interface ge-0/0/2.0;
            interface ge-0/0/3.0;
            interface ge-0/0/4.0;
            interface ge-0/0/5.0;
        }
    }
    ldp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
}
policy-options {
    policy-statement lbp {
        then {
            load-balance per-packet;
        }
    }
}
routing-instances {
    evpn-test {
        instance-type virtual-switch;
        interface ge-0/0/9.10;
        route-distinguisher 65432:10;
        vrf-target target:65432:10;
        protocols {
            evpn {
                extended-vlan-list 10;
            }
        }
        bridge-domains {
            bd10 {
                domain-type bridge;
                vlan-id 10;
                bridge-options {
                    interface ge-0/0/9.10;
                }
            }
        }
    }
}

[edit]
lab@IX# 
show | no-more 
## Last changed: 2018-10-22 13:23:54 UTC
version 14.1R1.10;
system {
    host-name GS;
    root-authentication {
        encrypted-password "$1$iiqdh9ru$CBQygri2MkpfgtgdGo8GO1"; ## SECRET-DATA
    }
    login {
        user lab {
            uid 2000;
            class super-user;
            authentication {
                encrypted-password "$1$oW1NeMUu$N7IVMfy8GfJ02jzQzJ39h/"; ## SECRET-DATA
            }
        }
    }
    services {
        telnet {
            connection-limit 5;
        }
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    ge-0/0/0 {
        description "GS <> IX #1";
        mtu 2000;
        mac 50:01:00:02:00:02;
        unit 0 {
            family inet {
                address 10.0.0.2/30;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        description "GS <> IX #1";
        mtu 2000;
        mac 50:01:00:02:00:03;
        unit 0 {
            family inet {
                address 10.0.1.2/30;
            }
            family mpls;
        }
    }
    ge-0/0/2 {
        description "GS <> DC2 #1";
        mtu 2000;
        mac 50:01:00:02:00:04;
        unit 0 {
            family inet {
                address 10.0.0.17/30;
            }
            family mpls;
        }
    }
    ge-0/0/3 {
        description "GS <> DC2 #2";
        mtu 2000;
        mac 50:01:00:02:00:05;
        unit 0 {
            family inet {
                address 10.0.1.17/30;
            }
            family mpls;
        }
    }
    ge-0/0/4 {
        description "GS <> AM6 #1";
        mtu 2000;
        mac 50:01:00:02:00:06;
        unit 0 {
            family inet {
                address 10.0.0.13/30;
            }
            family mpls;
        }
    }
    ge-0/0/5 {
        description "GS <> AM6 #2";
        mtu 2000;
        mac 50:01:00:02:00:07;
        unit 0 {
            family inet {
                address 10.0.1.13/30;
            }
            family mpls;
        }
    }
    ge-0/0/6 {
        mac 50:01:00:02:00:08;
    }
    ge-0/0/7 {
        mac 50:01:00:02:00:09;
    }
    ge-0/0/8 {
        mac 50:01:00:02:00:0a;
    }
    ge-0/0/9 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        mac 50:01:00:02:00:0b;
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    em0 {
        unit 0 {
            family inet {
                address 192.168.56.10/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.10.10.2/32;
            }
        }
    }
}
routing-options {
    router-id 10.10.10.2;
    autonomous-system 65000;
    forwarding-table {
        export lbp;
    }
}
protocols {
    rsvp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    mpls {
        no-cspf;
        label-switched-path GS-to-IX {
            to 10.10.10.1;
        }
        label-switched-path GS-to-DC2 {
            to 10.10.10.3;
        }
        label-switched-path GS-to-AM6 {
            to 10.10.10.4;
        }
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    bgp {
        group EVPN {
            type internal;
            local-address 10.10.10.2;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            multipath;
            neighbor 10.10.10.1;
            neighbor 10.10.10.3;
            neighbor 10.10.10.4;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ge-0/0/0.0;
            interface ge-0/0/1.0;
            interface ge-0/0/2.0;
            interface ge-0/0/3.0;
            interface ge-0/0/4.0;
            interface ge-0/0/5.0;
        }
    }
    ldp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
}
policy-options {
    policy-statement lbp {
        then {
            load-balance per-packet;
        }
    }
}
routing-instances {
    evpn-test {
        instance-type virtual-switch;
        interface ge-0/0/9.10;
        route-distinguisher 65432:10;
        vrf-target target:65432:10;
        protocols {
            evpn {
                extended-vlan-list 10;
            }
        }
        bridge-domains {
            bd10 {
                domain-type bridge;
                vlan-id 10;
                bridge-options {
                    interface ge-0/0/9.10;
                }
            }
        }
    }
}

[edit]
lab@GS# 
show | no-more 
## Last changed: 2018-10-22 13:23:12 UTC
version 14.1R1.10;
system {
    host-name DC2;
    root-authentication {
        encrypted-password "$1$iiqdh9ru$CBQygri2MkpfgtgdGo8GO1"; ## SECRET-DATA
    }
    login {
        user lab {
            uid 2000;
            class super-user;
            authentication {
                encrypted-password "$1$oW1NeMUu$N7IVMfy8GfJ02jzQzJ39h/"; ## SECRET-DATA
            }
        }
    }
    services {
        telnet {
            connection-limit 5;
        }
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    ge-0/0/0 {
        description "DC2 <> AM6 #1";
        mtu 2000;
        mac 50:01:00:03:00:02;
        unit 0 {
            family inet {
                address 10.0.0.25/30;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        description "DC2 <> AM6 #2";
        mtu 2000;
        mac 50:01:00:03:00:03;
        unit 0 {
            family inet {
                address 10.0.1.25/30;
            }
            family mpls;
        }
    }
    ge-0/0/2 {
        description "DC2 <> GS #1";
        mtu 2000;
        mac 50:01:00:03:00:04;
        unit 0 {
            family inet {
                address 10.0.0.18/30;
            }
            family mpls;
        }
    }
    ge-0/0/3 {
        description "DC2 <> GS #2";
        mtu 2000;
        mac 50:01:00:03:00:05;
        unit 0 {
            family inet {
                address 10.0.1.18/30;
            }
            family mpls;
        }
    }
    ge-0/0/4 {
        description "DC2 <> IX #1";
        mtu 2000;
        mac 50:01:00:03:00:06;
        unit 0 {
            family inet {
                address 10.0.0.10/30;
            }
            family mpls;
        }
    }
    ge-0/0/5 {
        description "DC2 <> IX #2";
        mtu 2000;
        mac 50:01:00:03:00:07;
        unit 0 {
            family inet {
                address 10.0.1.10/30;
            }
             family mpls;
        }
    }
    ge-0/0/6 {
        mac 50:01:00:03:00:08;
    }
    ge-0/0/7 {
        mac 50:01:00:03:00:09;
    }
    ge-0/0/8 {
        mac 50:01:00:03:00:0a;
    }
    ge-0/0/9 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        mac 50:01:00:03:00:0b;
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    em0 {
        unit 0 {
            family inet {
                address 192.168.56.10/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.10.10.3/32;
            }
        }
    }
}
routing-options {
    router-id 10.10.10.3;
    autonomous-system 65000;
    forwarding-table {
        export lbp;
    }
}
protocols {
    rsvp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    mpls {
        no-cspf;
        label-switched-path DC2-to-IX {
            to 10.10.10.1;
        }
        label-switched-path DC2-to-GS {
            to 10.10.10.2;
        }
        label-switched-path DC2-to-AM6 {
            to 10.10.10.4;
        }
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    bgp {
        group EVPN {
            type internal;
            local-address 10.10.10.3;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            multipath;
            neighbor 10.10.10.1;
            neighbor 10.10.10.2;
            neighbor 10.10.10.4;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ge-0/0/0.0;
            interface ge-0/0/1.0;
            interface ge-0/0/2.0;
            interface ge-0/0/3.0;
            interface ge-0/0/4.0;
            interface ge-0/0/5.0;
        }
    }
    ldp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
}
policy-options {
    policy-statement lbp {
        then {
            load-balance per-packet;
        }
    }
}
routing-instances {
    evpn-test {
        instance-type virtual-switch;
        interface ge-0/0/9.10;
        route-distinguisher 65432:10;
        vrf-target target:65432:10;
        protocols {
            evpn {
                extended-vlan-list 10;
            }
        }
        bridge-domains {
            bd10 {
                domain-type bridge;
                vlan-id 10;
                bridge-options {
                    interface ge-0/0/9.10;
                }
            }
        }
    }
}

[edit]
lab@DC2# 
show | no-more 
## Last changed: 2018-10-22 13:23:34 UTC
version 14.1R1.10;
system {
    host-name AM6;
    root-authentication {
        encrypted-password "$1$iiqdh9ru$CBQygri2MkpfgtgdGo8GO1"; ## SECRET-DATA
    }
    login {
        user lab {
            uid 2000;
            class super-user;
            authentication {
                encrypted-password "$1$oW1NeMUu$N7IVMfy8GfJ02jzQzJ39h/"; ## SECRET-DATA
            }
        }
    }
    services {
        telnet {
            connection-limit 5;
        }
    }
    syslog {
        user * {
            any emergency;
        }
        file messages {
            any notice;
            authorization info;
        }
        file interactive-commands {
            interactive-commands any;
        }
    }
}
interfaces {
    ge-0/0/0 {
        description "AM6 <> IX #1";
        mtu 2000;
        mac 50:01:00:04:00:02;
        unit 0 {
            family inet {
                address 10.0.0.6/30;
            }
            family mpls;
        }
    }
    ge-0/0/1 {
        description "AM6 <> IX #2";
        mtu 2000;
        mac 50:01:00:04:00:03;
        unit 0 {
            family inet {
                address 10.0.1.6/30;
            }
            family mpls;
        }
    }
    ge-0/0/2 {
        description "IX <> DC2 #1";
        mtu 2000;
        mac 50:01:00:04:00:04;
        unit 0 {
            family inet {
                address 10.0.0.26/30;
            }
            family mpls;
        }
    }
    ge-0/0/3 {
        description "IX <> DC2 #2";
        mtu 2000;
        mac 50:01:00:04:00:05;
        unit 0 {
            family inet {
                address 10.0.1.26/30;
            }
            family mpls;
        }
    }
    ge-0/0/4 {
        description "AM6 <> GS #1";
        mtu 2000;
        mac 50:01:00:04:00:06;
        unit 0 {
            family inet {
                address 10.0.0.14/30;
            }
            family mpls;
        }
    }
    ge-0/0/5 {
        description "AM6 <> GS #2";
        mtu 2000;
        mac 50:01:00:04:00:07;
        unit 0 {
            family inet {
                address 10.0.1.14/30;
            }
            family mpls;
        }
    }
    ge-0/0/6 {
        mac 50:01:00:04:00:08;
    }
    ge-0/0/7 {
        mac 50:01:00:04:00:09;
    }
    ge-0/0/8 {
        mac 50:01:00:04:00:0a;
    }
    ge-0/0/9 {
        flexible-vlan-tagging;
        encapsulation flexible-ethernet-services;
        mac 50:01:00:04:00:0b;
        unit 10 {
            family bridge {
                interface-mode trunk;
                vlan-id-list 10;
            }
        }
    }
    em0 {
        unit 0 {
            family inet {
                address 192.168.56.10/24;
            }
        }
    }
    lo0 {
        unit 0 {
            family inet {
                address 10.10.10.4/32;
            }
        }
    }
}
routing-options {
    router-id 10.10.10.4;
    autonomous-system 65000;
    forwarding-table {
        export lbp;
    }
}
protocols {
    rsvp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    mpls {
        no-cspf;
        label-switched-path AM6-to-IX {
            to 10.10.10.1;
        }
        label-switched-path AM6-to-GS {
            to 10.10.10.2;
        }
        label-switched-path AM6-to-DC2 {
            to 10.10.10.3;
        }
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
    bgp {
        group EVPN {
            type internal;
            local-address 10.10.10.4;
            family inet-vpn {
                unicast;
            }
            family evpn {
                signaling;
            }
            multipath;
            neighbor 10.10.10.1;
            neighbor 10.10.10.2;
            neighbor 10.10.10.3;
        }
    }
    ospf {
        traffic-engineering;
        area 0.0.0.0 {
            interface lo0.0 {
                passive;
            }
            interface ge-0/0/0.0;
            interface ge-0/0/1.0;
            interface ge-0/0/2.0;
            interface ge-0/0/3.0;
            interface ge-0/0/4.0;
            interface ge-0/0/5.0;
        }
    }
    ldp {
        interface ge-0/0/0.0;
        interface ge-0/0/1.0;
        interface ge-0/0/2.0;
        interface ge-0/0/3.0;
        interface ge-0/0/4.0;
        interface ge-0/0/5.0;
    }
}
policy-options {
    policy-statement lbp {
        then {
            load-balance per-packet;
        }
    }
}
routing-instances {
    evpn-test {
        instance-type virtual-switch;
        interface ge-0/0/9.10;
        route-distinguisher 65432:10;
        vrf-target target:65432:10;
        protocols {
            evpn {
                extended-vlan-list 10;
            }
        }
        bridge-domains {
            bd10 {
                domain-type bridge;
                vlan-id 10;
                bridge-options {
                    interface ge-0/0/9.10;
                }
            }
        }
    }
}

[edit]
lab@AM6# 

Below is the output for:

  • bgp sum
  • evpn database
  • route
run show bgp summary 
Groups: 1 Peers: 3 Down peers: 0
Table          Tot Paths  Act Paths Suppressed    History Damp State    Pending
bgp.l3vpn.0          
                       0          0          0          0          0          0
bgp.evpn.0           
                       6          6          0          0          0          0
Peer                     AS      InPkt     OutPkt    OutQ   Flaps Last Up/Dwn State|#Active/Received/Accepted/Damped...
10.10.10.2            65000        351        352       0       0     2:34:53 Establ
  bgp.l3vpn.0: 0/0/0/0
  bgp.evpn.0: 2/2/2/0
  evpn-test.evpn.0: 2/2/2/0
  __default_evpn__.evpn.0: 0/0/0/0
10.10.10.3            65000        349        351       0       0     2:34:53 Establ
  bgp.l3vpn.0: 0/0/0/0
  bgp.evpn.0: 2/2/2/0
  evpn-test.evpn.0: 2/2/2/0
  __default_evpn__.evpn.0: 0/0/0/0
10.10.10.4            65000        351        351       0       0     2:34:53 Establ
  bgp.l3vpn.0: 0/0/0/0
  bgp.evpn.0: 2/2/2/0                   
  evpn-test.evpn.0: 2/2/2/0
  __default_evpn__.evpn.0: 0/0/0/0

[edit]
lab@IX# 
run show evpn database 
Instance: evpn-test
VLAN  MAC address        Origin           Timestamp        IP address
10    00:50:01:00:09:00  ge-0/0/9.10      Oct 22 11:52:54
10    00:50:01:00:0a:00  10.10.10.3       Oct 22 11:53:10
10    00:50:01:00:0b:00  10.10.10.4       Oct 22 11:53:03
10    00:50:01:00:0c:00  10.10.10.2       Oct 22 11:53:01

[edit]
lab@IX# 
run show route | no-more 

inet.0: 25 destinations, 25 routes (25 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.0.0.0/30        *[Direct/0] 00:14:41
                    > via ge-0/0/0.0
10.0.0.1/32        *[Local/0] 5d 06:01:42
                      Local via ge-0/0/0.0
10.0.0.4/30        *[Direct/0] 00:14:41
                    > via ge-0/0/2.0
10.0.0.5/32        *[Local/0] 5d 06:01:42
                      Local via ge-0/0/2.0
10.0.0.8/30        *[Direct/0] 5d 06:01:42
                    > via ge-0/0/4.0
10.0.0.9/32        *[Local/0] 5d 06:01:42
                      Local via ge-0/0/4.0
10.0.0.12/30       *[OSPF/10] 00:14:40, metric 2
                    > to 10.0.0.2 via ge-0/0/0.0
                      to 10.0.1.2 via ge-0/0/1.0
                      to 10.0.0.6 via ge-0/0/2.0
                      to 10.0.1.6 via ge-0/0/3.0
10.0.0.16/30       *[OSPF/10] 00:14:40, metric 2
                      to 10.0.0.2 via ge-0/0/0.0
                      to 10.0.1.2 via ge-0/0/1.0
                      to 10.0.0.10 via ge-0/0/4.0
                    > to 10.0.1.10 via ge-0/0/5.0
10.0.0.24/30       *[OSPF/10] 00:14:40, metric 2
                    > to 10.0.0.6 via ge-0/0/2.0
                      to 10.0.1.6 via ge-0/0/3.0
                      to 10.0.0.10 via ge-0/0/4.0
                      to 10.0.1.10 via ge-0/0/5.0
10.0.1.0/30        *[Direct/0] 00:14:41
                    > via ge-0/0/1.0
10.0.1.1/32        *[Local/0] 5d 06:01:42
                      Local via ge-0/0/1.0
10.0.1.4/30        *[Direct/0] 00:14:41
                    > via ge-0/0/3.0
10.0.1.5/32        *[Local/0] 5d 06:01:42
                      Local via ge-0/0/3.0
10.0.1.8/30        *[Direct/0] 5d 06:01:42
                    > via ge-0/0/5.0
10.0.1.9/32        *[Local/0] 5d 06:01:42
                      Local via ge-0/0/5.0
10.0.1.12/30       *[OSPF/10] 00:14:40, metric 2
                      to 10.0.0.2 via ge-0/0/0.0
                    > to 10.0.1.2 via ge-0/0/1.0
                      to 10.0.0.6 via ge-0/0/2.0
                      to 10.0.1.6 via ge-0/0/3.0
10.0.1.16/30       *[OSPF/10] 00:14:40, metric 2
                    > to 10.0.0.2 via ge-0/0/0.0
                      to 10.0.1.2 via ge-0/0/1.0
                      to 10.0.0.10 via ge-0/0/4.0
                      to 10.0.1.10 via ge-0/0/5.0
10.0.1.24/30       *[OSPF/10] 00:14:40, metric 2
                      to 10.0.0.6 via ge-0/0/2.0
                    > to 10.0.1.6 via ge-0/0/3.0
                      to 10.0.0.10 via ge-0/0/4.0
                      to 10.0.1.10 via ge-0/0/5.0
10.10.10.1/32      *[Direct/0] 5d 06:53:51
                    > via lo0.0
10.10.10.2/32      *[OSPF/10] 00:14:40, metric 1
                      to 10.0.0.2 via ge-0/0/0.0
                    > to 10.0.1.2 via ge-0/0/1.0
10.10.10.3/32      *[OSPF/10] 5d 06:00:36, metric 1
                    > to 10.0.0.10 via ge-0/0/4.0
                      to 10.0.1.10 via ge-0/0/5.0
10.10.10.4/32      *[OSPF/10] 00:14:40, metric 1
                      to 10.0.0.6 via ge-0/0/2.0
                    > to 10.0.1.6 via ge-0/0/3.0
192.168.56.0/24    *[Direct/0] 5d 08:27:49
                    > via em0.0
192.168.56.10/32   *[Local/0] 5d 08:27:49
                      Local via em0.0
224.0.0.5/32       *[OSPF/10] 5d 06:01:42, metric 1
                      MultiRecv

inet.3: 3 destinations, 6 routes (3 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

10.10.10.2/32      *[RSVP/7/1] 00:14:36, metric 1
                    > to 10.0.0.2 via ge-0/0/0.0, label-switched-path IX-to-GS
                    [LDP/9] 00:14:39, metric 1
                      to 10.0.0.2 via ge-0/0/0.0
                    > to 10.0.1.2 via ge-0/0/1.0
10.10.10.3/32      *[RSVP/7/1] 5d 05:32:38, metric 1
                    > to 10.0.1.10 via ge-0/0/5.0, label-switched-path IX-to-DC2
                    [LDP/9] 00:15:37, metric 1
                    > to 10.0.0.10 via ge-0/0/4.0
                      to 10.0.1.10 via ge-0/0/5.0
10.10.10.4/32      *[RSVP/7/1] 00:14:36, metric 1
                    > to 10.0.0.6 via ge-0/0/2.0, label-switched-path IX-to-AM6
                    [LDP/9] 00:14:39, metric 1
                      to 10.0.0.6 via ge-0/0/2.0
                    > to 10.0.1.6 via ge-0/0/3.0

mpls.0: 20 destinations, 20 routes (20 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

0                  *[MPLS/0] 5d 05:40:17, metric 1
                      to table inet.0
0(S=0)             *[MPLS/0] 5d 05:40:17, metric 1
                      to table mpls.0
1                  *[MPLS/0] 5d 05:40:17, metric 1
                      Receive
2                  *[MPLS/0] 5d 05:40:17, metric 1
                      to table inet6.0
2(S=0)             *[MPLS/0] 5d 05:40:17, metric 1
                      to table mpls.0
13                 *[MPLS/0] 5d 05:40:17, metric 1
                      Receive
299776             *[LDP/9] 00:15:37, metric 1
                      to 10.0.0.10 via ge-0/0/4.0, Pop      
                    > to 10.0.1.10 via ge-0/0/5.0, Pop      
299776(S=0)        *[LDP/9] 00:15:37, metric 1
                      to 10.0.0.10 via ge-0/0/4.0, Pop      
                    > to 10.0.1.10 via ge-0/0/5.0, Pop      
299792             *[LDP/9] 00:14:39, metric 1
                    > to 10.0.0.2 via ge-0/0/0.0, Pop      
                      to 10.0.1.2 via ge-0/0/1.0, Pop      
299792(S=0)        *[LDP/9] 00:14:39, metric 1
                    > to 10.0.0.2 via ge-0/0/0.0, Pop      
                      to 10.0.1.2 via ge-0/0/1.0, Pop      
299808             *[LDP/9] 00:14:39, metric 1
                    > to 10.0.0.6 via ge-0/0/2.0, Pop      
                      to 10.0.1.6 via ge-0/0/3.0, Pop      
299808(S=0)        *[LDP/9] 00:14:39, metric 1
                      to 10.0.0.6 via ge-0/0/2.0, Pop      
                    > to 10.0.1.6 via ge-0/0/3.0, Pop      
299824             *[EVPN/7] 02:09:21
                      to table evpn-test.evpn.0
299888             *[EVPN/7] 02:30:57
                      to table evpn-test.evpn.0
299904             *[EVPN/7] 02:29:09, metric2 1
                    > to 10.0.0.2 via ge-0/0/0.0, label-switched-path IX-to-GS
299920             *[EVPN/7] 02:26:48, metric2 1
                    > to 10.0.1.10 via ge-0/0/5.0, label-switched-path IX-to-DC2
299936             *[EVPN/7] 02:25:08, metric2 1
                    > to 10.0.0.6 via ge-0/0/2.0, label-switched-path IX-to-AM6
299952             *[EVPN/7] 02:09:15, metric2 1
                    > to 10.0.0.2 via ge-0/0/0.0, label-switched-path IX-to-GS
299968             *[EVPN/7] 02:09:13, metric2 1
                    > to 10.0.0.6 via ge-0/0/2.0, label-switched-path IX-to-AM6
299984             *[EVPN/7] 02:09:06, metric2 1
                    > to 10.0.1.10 via ge-0/0/5.0, label-switched-path IX-to-DC2

bgp.evpn.0: 6 destinations, 6 routes (6 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:65432:10::10::00:50:01:00:0a:00/304               
                   *[BGP/170] 02:09:06, localpref 100, from 10.10.10.3
                      AS path: I, validation-state: unverified
                    > to 10.0.1.10 via ge-0/0/5.0, label-switched-path IX-to-DC2
2:65432:10::10::00:50:01:00:0b:00/304               
                   *[BGP/170] 02:09:13, localpref 100, from 10.10.10.4
                      AS path: I, validation-state: unverified
                    > to 10.0.0.6 via ge-0/0/2.0, label-switched-path IX-to-AM6
2:65432:10::10::00:50:01:00:0c:00/304               
                   *[BGP/170] 02:09:15, localpref 100, from 10.10.10.2
                      AS path: I, validation-state: unverified
                    > to 10.0.0.2 via ge-0/0/0.0, label-switched-path IX-to-GS
3:65432:10::10::10.10.10.2/304               
                   *[BGP/170] 02:29:09, localpref 100, from 10.10.10.2
                      AS path: I, validation-state: unverified
                    > to 10.0.0.2 via ge-0/0/0.0, label-switched-path IX-to-GS
3:65432:10::10::10.10.10.3/304               
                   *[BGP/170] 02:26:48, localpref 100, from 10.10.10.3
                      AS path: I, validation-state: unverified
                    > to 10.0.1.10 via ge-0/0/5.0, label-switched-path IX-to-DC2
3:65432:10::10::10.10.10.4/304               
                   *[BGP/170] 02:25:08, localpref 100, from 10.10.10.4
                      AS path: I, validation-state: unverified
                    > to 10.0.0.6 via ge-0/0/2.0, label-switched-path IX-to-AM6

evpn-test.evpn.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)
+ = Active Route, - = Last Active, * = Both

2:65432:10::10::00:50:01:00:09:00/304               
                   *[EVPN/170] 02:09:21
                      Indirect
2:65432:10::10::00:50:01:00:0a:00/304               
                   *[BGP/170] 02:09:06, localpref 100, from 10.10.10.3
                      AS path: I, validation-state: unverified
                    > to 10.0.1.10 via ge-0/0/5.0, label-switched-path IX-to-DC2
2:65432:10::10::00:50:01:00:0b:00/304               
                   *[BGP/170] 00:14:36, localpref 100, from 10.10.10.4
                      AS path: I, validation-state: unverified
                    > to 10.0.0.6 via ge-0/0/2.0, label-switched-path IX-to-AM6
2:65432:10::10::00:50:01:00:0c:00/304               
                   *[BGP/170] 00:14:36, localpref 100, from 10.10.10.2
                      AS path: I, validation-state: unverified
                    > to 10.0.0.2 via ge-0/0/0.0, label-switched-path IX-to-GS
3:65432:10::10::10.10.10.1/304               
                   *[EVPN/170] 02:30:57
                      Indirect
3:65432:10::10::10.10.10.2/304               
                   *[BGP/170] 00:14:36, localpref 100, from 10.10.10.2
                      AS path: I, validation-state: unverified
                    > to 10.0.0.2 via ge-0/0/0.0, label-switched-path IX-to-GS
3:65432:10::10::10.10.10.3/304               
                   *[BGP/170] 02:26:48, localpref 100, from 10.10.10.3
                      AS path: I, validation-state: unverified
                    > to 10.0.1.10 via ge-0/0/5.0, label-switched-path IX-to-DC2
3:65432:10::10::10.10.10.4/304               
                   *[BGP/170] 00:14:36, localpref 100, from 10.10.10.4
                      AS path: I, validation-state: unverified
                    > to 10.0.0.6 via ge-0/0/2.0, label-switched-path IX-to-AM6

[edit]
lab@IX# 
comments powered by Disqus